Comeback

And that’s it! over 3 months since I ever had a thought about blogging! Maybe I wouldn’t make a come back this soon if Matt over there didn’t wrote that scary post about the recent WordPress worm. I’m invulnerable to it since I turned off user registration since day 1 :P. However, lacking behind in updates isn’t something an IT professional should get used to so I paid 3 hours to have this blog upgraded and moved to a new domain, since my old one is going to expire in December anyways (The Koreans hosting it decided to cheapen themselves earlier this year by violating their own mission to bring free domains. Oh well).

Not the first time I move nor upgrade; in fact maybe I should consider doing WP upgrades and moves for other people for profit: it’s so smooth it almost feels good 😛 Can you imagine it? I described the process once before already but this time the situation is a bit different: I’m not moving host, everything is already in the database so Import/Export isn’t really necessary (and it costs time + bandwidth to do so).

1. I installed WP at the new domain and copy all the plug-in and upload over

2. I crafted the wp-config.php for the new domain to make sure all changes are dealt with. This time there is no change from WP 2.7 to 2.8

3. I changed the domain in the CP and have to login to the new domain. It says a database upgrade is needed, I hit next and got a blank admin screen. Befuddled

4. Google a bit, the first hit says this is caused by plugins, I moved them out and reload, it worked! All the posts are there and the theme is kept

5. Add the plugins back one by one until I found the one causing problem: No follow in posts

6. Edit the images to point to the new domain: if I were to use Import/Export like last time, the server will have to pull all the file over (which is on the same server, a waste of bandwidth) but the image URL in the posts will be automatically updated. This time I just move them over to the new domain’s directory, so I updated the posts’ images by two simple SQL queries:

UPDATE wp_posts SET guid = replace(guid, 'http://silentwind.co.cc', 'silentwind.za.net');
UPDATE wp_posts SET post_content = replace(post_content, 'http://silentwind.co.cc', 'silentwind.za.net');

Images should be displaying by now.

More disassembly

I concluded my last blog post streak with a disassembling post, it’s quite appropriate to have another one right now to celebrate my comeback 😛 This is going to be a short one: my TV Box which is used to watch analog TV with my computer’s monitor.

It used to work fine when new but when it’s about 6 months of age, its image quality gradually decrease until I’m more frustrated by watching TV with it than not at all, at which point I thrown it into storage. When I pulled it back out 2 weeks ago for a sudden need, it worked. But the next day it refused to display most of the channel :/

So I took it apart, maybe I can do something about it, it’s better than being furious at it anyway.

Pict0031

To the top is the outer case and the speaker (the one with a couple of wire dangling). To the bottom is the main circuit board, which is also everything. All the components are soldered to the board so nothing else could be taken apart without damaging it

Pict0033

Close up of the mainboard

I noticed a variable resistor above the chip in the middle (the one with the number 4 on it). I plugged everything in, turned it on and start tuning it left and right slowly to no avail. Later, I decided to turn it all the way to the left (so it would rise and possibly allow me to take something else out :P), this time it gives crystal clear picture and got all the channels. What confuses me is if from the start, it was working well because the resistor were at the top then what kind of mysterious force pushed it down later?

Chinese stuff after all, heh.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.